Crystal Android Device and MDM Service Issues

Incident Report for Crystal Studios

Monitoring

Unfortunately, we are closing ALL Android Devices in our workspace. Staff will receive an iPhone 17 Pro, or an iPhone 16 Pro Max. Thank you all for your cooperation.
Posted Oct 30, 2025 - 05:59 UTC

Identified

We have been made aware of an issue occurring with all the Samsung (Android) devices (no iOS devices were affected). We are in the mist of fixing this. (22/10/2025)
Posted Oct 22, 2025 - 01:45 UTC
This incident affects: Crystal Device Management for Android based Mobile Devices (Crystal Studios | Android 13 MDM for Work Devices).